1. 小型企业组网

小型企业的特点:

1. 设备的价格便宜;二手的、TPLINK、DLINK

2. 组网结构相对简单;接入、出口;

3. 安全性基本没要求;

4. 设备和线路冗余没有要求;

1) 二层

设备接入,有线、无线网络

技术:VLAN TRUNK

2) 三层

网关SVI地址,路由控制

3) 出口

拨号上网,端口映射

交换机-PC对接 使用ACCESS

交换机-交换机 使用TRUNK

交换机-路由器 使用ACCESS

2. 二层交换配置

2.1. 配置ACCESS接口

1. 新建VLAN

Vlan 20

Vlan 30

2. 将F0/0接口关联至VLAN2

Int f0/0

Sw mo ac

Sw acc vlan 20

2.2. 配置TRUNK

ISL:思科私有的,思科自家的设备才能运行;

DOT1Q:共有的,任意厂家都能使用;

Int f0/0

Sw trun en dot1q

Sw mo trunk

3. 三层交换配置

3.1. SVI

交换机的虚拟接口,三层交换机上的网关;

1) 新建VLAN

VLAN 20

VLAN 30

2) 配置SVI地址

Int vlan 20

Ip add 192.168.20.254 255.255.255.0

3.2. 静态路由配置

ip route 0.0.0.0 0.0.0.0 172.16.1.2

4. 出口路由器配置

4.1. NAT

4.1.1. 配置ACL

access-list 1 permit 192.168.20.0 0.0.0.255

4.1.2. 关联NAT接口

Int f0/0

ip nat inside

int f0/1

ip nat outside

4.1.3. 调用命令

ip nat inside source list 1 interface FastEthernet0/1 overload

流量从inside接口源地址为ACL 1命中的,流经F0/1接口的进行端口复用NAT

4.2. 静态路由(回程路由)

ip route 192.168.20.0 255.255.255.0 172.16.1.1

5. 管理设备

5.1. telnet

远程管理网络设备

line vty 0 4

password funnet

login

enable password funnet

service password-encryption

5.2. 远程管理设备

接入的二层交换机,至少能配置一个IP地址,一条路由;

interface Vlan1

ip address 10.1.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 10.1.1.254

5.3. SNMP简单网管协议

设备配置备份,流量监控,下发配置。

6. 无线网络

6.1. 无线级别

家用级别的无线设备

Tplink dlink无线作为接入;

网件、华硕

商用级别的无线设备

ARUBA、CISCO、锐捷、H3C、华为

6.2. 组网方式

AC+AP组网

1) DHCP中继

2) DHCP OPTION 43

3) 集中式转发

4) AC控制器管理方式

6.3. AC+AP的特点

管理方便:批量管理无线

无缝漫游:无感知的网络全覆盖

集中式转发:安全可控,只需要防护AC的安全性;

无配置上线:不需要做任何的配置,可直接上线使用;

7. 其他

对于一个网络需要顺还需要下列一些技术或者设备;

路由交换机,就像修路一样,只是单纯把路修通了,剩下的安全,稳定性,管理如下

VPN的接入:外部人员接入公司内网;

防火墙:保护重要的区域;

冗余技术:防止单点故障;

存储:FTP、群晖、DELL、HP;

服务器:DELL、HP、万全、邮件服务器、CRM、财务软件、数据库

ACG:流量的控制,可控哪些时间段能够访问什么网站;

IPS:特征库对比病毒库;

WAF:针对挂载网站进行防护;

网管系统:监控整个网络的运行情况,认证DOT1X、PORTAL;